LeeDroid 2.3d erschienen

nachdem es den Patch 2.3c nur als Update Patch gab, ist jetzt LeeDroid 2.3d erschienen, der noch einige Fehlerbereinigungen mehr beinhaltet: und wieder als komplettes ROM angeboten wird:
V2.3d Full build *LATEST*

* Patch auf HTC OTA 2.29.405.5
* Update: Busybox 1.7.3 > 1.18.1
* AdFree hosts update
* Fix: internationales Datumsformat (thanks to aaargh777)
* Erhöhte Dalvik VM heap size 24m > 32m
* Einige build.prop edits
* Locales updated, neu sind griechisch und japanisch
* Fix: vold.fstab (sd-mount Problem)
* Zipalign bei boot für data/app/ (Beschleunigt Start der Apps, kann aber den Bootvorgang verlängern bei Installation von vielen neuen Apps)
* Update: Google street view
* Update: Titanium backup
* Update: AdFree

Ein Update sollte ohne Wipe klappen (macht aber trotzdem ein Backup!), bei Schwierigkeiten nach Update natürlich als erstes Wipen!
Das Rom gibt es im LeeDroid-Artikel zum download.

Diskussionen zum neuen ROM können gerne im Forum geführt werden.

avatar

Über Brain McFly

Rooter aus Leidenschaft, Nerd, Erklärbär ;o)

66 thoughts on “LeeDroid 2.3d erschienen”

  1. avatar JayJay sagt:

    Wenn ich das Rom über mein vorhandenes Leerdroid installiere…bleiben dann die ganze einstellung, sms, appz weiterhin drauf oder muss ich alles neuinstallieren?

  2. avatar marse sagt:

    Wenn du es ohne wipe flashst bleiben deine Einstellungen erhalten.

  3. avatar Chris sagt:

    Moin
    beinhaltet diese Version jetzt noch was neues nach der 2.3c ???
    Oder ist es „nur“ die zusammenfassung der Versionen 2.3b + 2.3c zu einem kompletten Rom ?

    LG Chris

    1. avatar Onkel Fruf sagt:

      Hi,

      das würde mich auch interessieren.

      MfG

    2. avatar Brain McFly sagt:

      einfach mal das Changelog des ROMs mit dem Changelog des Patches vergleichen. Im ROM wurde noch einiges mehr gemacht….

  4. avatar plastikcity sagt:

    Habs ohne Wipe geflasht und ist alles gut.

  5. avatar Klaus sagt:

    Hi,
    hier hats auch ohne wipe gefunzt,einzige Problem ist jetzt bei Neustart/boot kommt:
    „SIM-Karte wurde gewechselt“.
    Habe dazu leider nichts gefunden,wenn jemand was rausbekommt bitte melden.
    Telefonieren etc. funzt ohne Probleme,ist also kein „böser“Fehler etc. 😉

  6. avatar kriz123 sagt:

    @ Alex, ja wo Du es sagst ! das selbe Problem hatte ich nach dem c Update auch. Werden später testen ob das immer noch so ist.

  7. avatar kriz123 sagt:

    Ups, Klaus meinte ich

  8. avatar Valerio sagt:

    Habe auch das Problem mit der Sim sowohl bei der C als auch bei der D Version.

    Im android-hilfe-forum hat man mir folgendes geraten:
    Hi,

    das Problem mit der Sim Karte hatte ich bei einer andern ROM, hier klappt alles.

    Problemlösung:

    – Die APN-Einstellungen auf Standard zurücksetzen
    – Neu booten
    – „Neue Sim Karte erkannt“ nochmals bestätigen

    Danach war zumindest bei mir die Meldung verschwunden

    Grüße

    Snap

    Habe es aber bisher noch nicht ausprobiert!

  9. avatar Klaus sagt:

    @Valerio:
    Yep,hat gefunzt,Meldung ist weg!
    Jetzt noch die APN wiederherstellen,dann ist alles Tutti.
    DANKE!

  10. avatar theo sagt:

    Hi,
    ich hab noch das 2.2 i auf meinem desire. muss ich jetzt einfach die zip datei auf mein handy knallen und dann flashen ?

  11. avatar theo sagt:

    und vor allem wie flash ich das neue rom? mach ich das mit dem rom manager oder reboote ich und wähle dort flash aus ?

    1. avatar Brain McFly sagt:

      ohne wipe über den ROM Manager flashen und Nandroid Backup machen.
      Bei Problemen wipen, neu flashen und mit Titanium Backup Apps und Einstellungen wieder herstellen…

  12. avatar theo sagt:

    hi
    habs auch ohne wipe von 2.2 i auf 2.3d geupdated. ohne probleme bis jetzt.
    danke

  13. avatar Sammy sagt:

    Hallo zusammen,

    seit dem Update auf 2.3d (von b) erhalte ich beim reeboot sowie beim Simkartenwechsel (dual sim adapter) eine Warnmeldung das die Simkarte gewechselt wäre (auch wenn eben beim Neustart dem nicht so ist).
    Die Meldung besagt durch ein tippen darauf käme man zur Konfiguration. Es öffnet sich aber nur ein schwarzes Fenster mit der Überschrift “Netzbetreiber” (oder so ähnlich) mit dem Back-button komme ich immerhin dort heraus und habe bis zum nächsten Reeboot oder SimWechsel erstmal Ruhe.

    Trotzdem blöd – wie verhindere ich das oder konfiguriere es richtig?

    Danke!
    Sammy

  14. avatar Klaus sagt:

    @Sammy:
    *grins*
    In Post #10,sollte die Lösung stehen.

    1. avatar Sammy sagt:

      Coole sache wenn man die apns zurück setzt sind plötzlich diverse vordefiniert und müssen nur noch ausgewählt werden. Ausgewählt sind die jetzt für beide sim Karten. Wenn’s jetzt noch funktioniert -großartig!

      1. avatar Sammy sagt:

        Ganz so großartig ist es leider nicht – zuvor (HTC firmware bzw. leedroid 2.3b) hatte ich für meine beiden Sim-Karten jeweils einen APN definiert und beim umschalten zwischen den SIMS funktionierte alles problemlos einwandfrei. Jede SIM „sah“ nur Ihren APN und gut war.

        Jetzt fragt das Tool jedesmal welches netz es ist wenn ich zwischen den SIM hin und herschalte und ich bin recht sicher, dass es auch länger dauert bis dann mobiles internet zur Verfügung steht 🙁

        Kann man den Entwickler auf so etwas hinweisen oder habt ihr einen Tipp für mich (Dual-Sim-Adapter)?

  15. avatar theo sagt:

    hi,
    wie bereits gesagt, hab ich mein desire von 2.2i auf 2.3.d geupdated.
    habe heute feststellen müssen, dass adfree überhaupt nicht mehr funktioniert.

    kann mir jemand nen tip geben, wie ich das wieder zum laufen bekomme ?

    1. avatar Sammy sagt:

      Probiere es mal mit einem update der app und dann mit der app einem update der host datei ggf zwischendurch neubooten. Wenn das nicht hilft -irgendwo findet sich eine Anleitung zur manuellen Konfiguration per usb via Shell.

      1. avatar theo sagt:

        wenn ich das app über das market updaten will, gibt es ne fehlermeldung. von wegen fehler beim parsen.

        wie geht das mit der manuellen konfiguration ?

  16. avatar Sossi sagt:

    Hey,
    hab so eben 2.3d aufgespielt hat auch alles einwandfrei funktioniert nach dem das Handy einmal komplett gebootet hat habe ich es ausgeschalten dann wollte ich es wieder einschalten und jetzt hängt es in einem Bootloop ?
    Weiss vielleicht jemand woran das liegt ?
    Leedroid Update war ohne wipe !

    Danke

  17. avatar Yoggie sagt:

    ne kurzte dumme frage… wo finde ich die apn einstellung beim desire? 🙁
    steh irgendwie aufm schlauch

  18. avatar Yoggie sagt:

    okay hat sich erledigt… habe mir eben den pitis espresso mod geflasht und nun kommt die meldung nicht mehr

  19. avatar Skydiver sagt:

    mit Wipe geflasht – alles bestens funktioniert – ohne Fehlermeldungen…
    Welche offizelle Version ist das? 2.2 oder 2.2.1?

    THX

    1. avatar Skydiver sagt:

      Hat jemand schon BrightSilence_Black_Espresso_2.2a dazu ausprobiert?

  20. avatar kriz123 sagt:

    Hab das erfolgreich geflasht. Funzt auch alles gut, nur das mit der Simkarte ist geblieben !!! werde mal die Beschrieben aus Post 10 versuchen.

    Jetzt mal ne andere Frage ! ich habe mir aus der Dropbox das Theme Blue_Carbon_Sense_UI_Full-v1.3b Installiert. Nach dem Start funktioniert aber iwie gar nichts meht, der sagt immer das mein Sense nicht mehr funktioniert wenn ich zB auf Kontakte gehen will. Woran kann das liegen, hab jetzt erst mal mein Backup zurück gespielt. Bis ich eine Lösung für das Problem gefunden habe

  21. avatar Sossi sagt:

    Wer kann mir helfen jedesmal wenn ich das Leedroid 2.3d flashe und mein handy neu boote landet es in einem Bootloop !!!! Ich habe kein plan was da los is ??

    Danke

  22. avatar kriz123 sagt:

    beachte das der erste Boot nach dem Flaschen wirklich sehr lange dauern kann. Bei mir war es gestern ca. ne halbe Stunde. Warte einfach mal ab. Gehe einfach mal davon aus, das es sicherlich Starten wird.

    Hab da auch noch eine Frage.

    hab ein theme gefunden Blue_Carbon_Sense_UI_Full-v1.3b-DPAD …

    was bedeutet dieses DPAD hinten, finde iwie keine Erklärung dafür

    thxxx schon mal

  23. avatar Sossi sagt:

    das erstemal hat er ja gebootet wenn ich das geräte aber dann neuboote landet es in einem bootloop beim HTC bildschirm !

  24. avatar kriz123 sagt:

    kommst du denn zu den Einstellungen, bin kein Experte.. wenn ja mal mal einen Wipe.. wenn Du nicht zu den Einstellungen kommst dann würde ich Dein letztes Backup wieder Neu draufspielen, danach dann leedroid neu runterladen und nochmal draufspielen. Vielleicht war die Version beschädigt, nach dem Download

    1. avatar Brain McFly sagt:

      kann ich nur recht geben: neu runterladen. Wipen und installieren. Dann erstmal schauen, ob das Problem immer noch da ist. Dann mit Titanium Bckup alles restaurieren. Wenns dann wieder abstürzt nochmal von vorn und nur apps und keine Systemeinstellungen wiederherstellen usw. Manchmal hängt sowas auch an einer App

  25. avatar Toubsn sagt:

    Hi,
    Habe ein Problem

    Habe Leedroid 2.3d + signierten Espresso Mod + die 2 updates davon geflasht. (bevor ich leedroid geflasht habe, habe ich einen wipe gemacht)
    und habe nun folgenden fehler

    Also.. Wenn ich bei set cpu 1190 einstelle dann schließen sich die apps einfach von alleine.. zb. Browser oder Album – wenn ich ein Foto maximiere. Wenn ich jetzt nur 1152 einstelle läuft alles problemlos? (soweit ich das jetzt gesehen habe)

    An was kann das Liegen?

    1. avatar Toubsn sagt:

      mir ist gerade noch aufgefallen, dass ich bei Quadrant einen besseren wert habe wenn ich bei set cpu 1152 einstelle..
      Jemand ne idee washie rlos ist? 😉

      1. avatar Toubsn sagt:

        Ausm Leedroid Artikel ausm xda forum

        •Some CPU’s may struggle with higher O/C values, if you experience instablilities try a lower clock speed.

        damit hätte sich mein anliegen wohl geklärt und vieleicht interesiert es ja noch einen.

  26. avatar kriz123 sagt:

    Braunschweig hast du ne Idee für meine Fragen im Artikel 26 & 28.

    Danke

  27. avatar kriz123 sagt:

    och man Brain meinte ich

    1. avatar Brain McFly sagt:

      dpad bedeutes dpad-wakeup, d.h. durch druck auf den Joystick kannst du dein desire aufwecken

      beim bluecarbon steht „NOTE – Wait for the official release of 1.6 by alexdiaz, as it will be based on the 2.29.405.2 HTC framework. If you attempt to install his 1.5 version on LeeDrOiD 2.3+, you may experience issues“
      es ist also noch auf dem alten 2.2er Franmework basierend, für das 2.3er leedroid musst du erst auf eine neue version warten

  28. avatar kriz123 sagt:

    cool ich Dank Dir Brain, dann werd ich mal auf die neue Version warten.

  29. avatar Jens sagt:

    HiHo,

    habe auch gerade geflasht und es hat alles wunderbar funktioniert.
    Allerdings habe ich eine Frage: Ist die framework Datei aus der d Version die gleiche wie aus dem c Patch???

    Ich frage wegen der Erstellung meiner Stausleiste. Kann ich die erstelle mit dem c framework nehmen oder sollte ich eine neue aus der d Version erstellen????

  30. avatar Masel sagt:

    Nabend !

    irgendwelche wirklichen Vorteile im 2.3D ?
    Ansonsten –> never change a fast running system 😛

    Prost

    Masel

    1. avatar Sammy sagt:

      Im Changelog sollest Du Antworten finden 😉
      u.A. sollte das zwischenzeitliche HTC Update wohl drin sein

  31. avatar Ole sagt:

    also ich hab grad von 2.2f + carbon espr. mod auf 2.3d ohne wipe geflasht…geht alles…dann espresso mod versucht…bootloop?was ist da los?

  32. avatar Ole sagt:

    auch erneuter restart war kein problem..kein bootloop oder so…nur mit dem carbon mod scheint was nicht ganz kompatibel zu sein. an signature v. hab ich natürlich gedacht und auch aus dem manuellen recovery geflasht. @ brain: ne idee?

  33. avatar kriz123 sagt:

    da scheint das selbe Problem zu sein wie bei mir im Post 27.

  34. avatar Ole sagt:

    Ja stimmt.nur ich komm garnicht erst zum Startbildschirm.pineingabe wird kurz eingeblendet und dann gehts zurück zum carbon espresso ladebildschirm usw.

  35. avatar Sammy sagt:

    Hallo zusammen, kann mir jemand bzgl. der in #19 beschriebenen Systematik weiterhelfen?

    Danke!
    Sammy

  36. avatar Skydiver sagt:

    Ist Euch etwas bei der Akkuleistung aufgefallen?
    Ich schaffte es vorher 1,5 Tage – jetzt ist nach 1 Tag Ende.
    Liegt es am 2.3d, am neuen JuiceDefender oder saugt mich ein App unbemerkt leer?

    THX

    1. avatar theo sagt:

      ich hab nach wie vor 2 tage akku

  37. avatar bjoern sagt:

    eigentlich tolle rom, allerdings ist bei mir auch die akkuleistung gesunken, genau wie bei skydiver. vorher fast zwei tage….jetzt muss ich zusehen das ich abends schnell nach hause komme an die steckdose !

    1. avatar Sammy sagt:

      Komisch – zunächst hätt ich gesagt: Unsicher wer weiß ob ich es nicht mehr genutzt habe. Seit dem letzten Laden stimmt aber etwas massiv nicht.

      Akku hat nur 16 STunden gehalten – davon waren gut 8 Stunden mein Schlaf auch in den anderen 8 Stunden habe ihc es nur mäßig genutzt. Laut Akkuverbrauch verteilt sich dieser zu 44% auf Android System, zu 15% auf Standby, zu 15% auf Display zu 14% auf Wlan zu 12% auf Telefon inaktiv.

      ?! Was läuft falsch? Tasker hat Nachts auf Flugmodus geschaltet, Wlan ist aus wenn das Telefon (wie meist auf dem Gesicht liegt) …

      Danke!
      Sammy

  38. avatar theo sagt:

    wie kann ich denn adfree manuell updaten? bei mir funkt das prog nicht unter 2.3d

    1. avatar Sammy sagt:

      adfree läßt sich über den market installieren dafür gab es letzte woche glaube ich an zwei tage bestimmt 6 updates. Wenn du das Programm dann startest gibt es eine Funktion zum Update der HOST Datei. Manchmal klappt das nicht – teilweise hilft ein reeboot und neuer versuch.

      Wenn das nicht hilft – google mal. Es gibt eine Anleitung wie man es manuell per Datenkabel und Konsole mit ein paar per copy und paste einfügbaren befehlen einrichtet 🙂

  39. avatar Ole sagt:

    Nochmal ne kleine Rückmeldung zu Post #44 und #45. Nach nem Wipe ist alles ok.Alle widgets funzen, auch kein „neue SIM-Karte“…neues espresso auf 2.29.405.5 basis und alles ist tutti.
    Nur falls noch jemand probleme mit den Dingen hatte.

  40. avatar Der Knipser sagt:

    am WE habe ich auch von 2.2f auf 2.3d geflashed (ohne wipe) und das aktuelle RadioRom drauf gemacht. Hat auch alles soweit geklappt. Beim ersten Starten kam bei mir auch die Fehlermeldung „SIM-Karte wurde gewechselt“. Nach Neustart war diese Meldung dann aber weg.
    Wenn ich jetzt ins Internet gehe (mit dem Dolphin Browser), bekomme ich die Fehlermeldung: „Unerwartetes Problem auf der SD-Karte – Schreibgeschütz bereitgestellt“ – das surfen klappt aber. Beim Market bekomme ich unter eigene Apps nur 6 angezeigt!! Wenn ich einen Barcode scanne, bekomme ich die Fehlermeldung „zum Download von …apk ist eine SD-Karte erforderlich“. Aus dem Market ist eine Installation möglich.
    HAt das mit den APN-Einstellungen zu tun (wie in Post #10)? Und wenn ja, wie bekomme ich die auf Standard zurückgesetzt? Oder sollte ich das ganze nochmal mit Wipe durchführen?

    Hat jemand eine Idee oder vielleicht das selbe Problem

    1. avatar Brain McFly sagt:

      klingt, als ob deine SD-Karte nicht gemountet wurde. Kannst du auf die SD-Karte zugreifen?

  41. avatar DerKnipser sagt:

    Ja, kann ich. Sowohl mit dem Astro-explorer als auch mit dem ES. Dateien öffnen und löschen. Funktioniert beides. Über den PC habe ich es noch nicht testen können.

    1. avatar Brain McFly sagt:

      Handy an den PC anschliessen und als Festplatte erkennen lassen. Dann Rechtsklick auf die SD Karte/Eigenschaften/Tools/Fehlerüberprüfung dann bei „Dateisystemfehler Automatisch Korrigieren“ einen Haken rein bei „Fehlerhafte Sektoren suchen/wiederherstellen“ keinen Haken setzen.

      und starten, warten und dann sollte es wieder gehen

  42. avatar DerKnipser sagt:

    Super – danke dir! Werde ich direkt morgen früh testen und dann berichten.

  43. avatar Der Knipser sagt:

    das mit dem Internet hat soweit geklappt – keine Fehlermeldung mehr. Meine Apps im Market werden aber immer noch nicht angezeigt – immer nur die schon beschriebenen 6 Apps. Neustart habe ich schon durchgeführt.

    1. avatar Der Knipser sagt:

      Hallo Brain,
      fällt dir zu dem Problem mit dem Market auch noch eine Lösung ein? Die Apps funktionieren alle, ich kann sie nur nicht über den Market aktualisieren.

      1. avatar Brain McFly sagt:

        vielleicht hilft eine sicherung mit Titanium Backup, anschließend Wipen, das ROM nochmal neu installeiren und mit TB alles zurück spielen…

  44. avatar Der Knipser sagt:

    so langsam bin ich ein wenig am Verzweifeln:
    – habe das Titanium- und Nandroid-Backup gemacht
    – dann den kompletten Inhalt der SD auf den PC geschoben
    – partitionieren der SD und Rückspielung der gesicherten SD-Daten
    – flashen von 2.3d über den Rom-Manager inkl. Wipe
    – danach mit Titanium die Apps zurückgespielt. Nach dem Neustart hat der sich ewig (ca. 40 min) beim Doiden „festgefahren“, deswegen Akku gezogen und ins Recovery.
    – das Ganze nochmal – jetzt hat´s geklappt. Allerdings werden die Ordner vom App Organizer sowie einige Widgets nicht angezeigt.

    Außerdem kann ich über den Market immer noch nur so 6 Apps unter „meine Apps“ sehen und entsprechend nur diese aktualisieren.

    Deswegen habe ich zur Probe mal das Nandroid-Backup von 2.2f zurückgespielt. Da ist es aber genauso, wieder nur die gleichen Apps anzeigbar. Daher das Nandroid-Backup von 2.3d zurückgespielt. Jetzt läuft wenigstens wieder alles – bis auf den Market.
    Wenn ich mir meine Apps über AndroidPIT ansehen will, bekomme ich folgende Fehlermeldung: „Fehler bei letzter Datenübertragung – „connect to /: 10.0.2.2: 80 time out“

    Schaue ich mir mein Konto bei Android Market auf dem PC an, sehe ich auch nur diese 6 Apps. Das bedeutet doch, dass die Verlinkung nicht mehr funktioniert – nur in der falschen Richtung. Kann ich diese Verbindung wieder herstellen, damit die Apps wieder in meinem Konto erscheinen?

    1. avatar Brain McFly sagt:

      schau mal im TB Artikel, ganz unten sind Lösungsansätze
      https://www.brutzelstube.de/2010/backup-mit-rootrechten-titanium-backup/

      meistens reicht es, irgendeine App aus dem market mal zu laden und schon ist alles wieder da

  45. avatar Der Knipser sagt:

    Hhmm, alles sehr merkwürdig! Im Market steht bei den Apps leider nur Gratis und NICHT installiert. Ich muss also jede App manuell neu installieren. Irgendwie scheint da die Verlinkung abhanden gekommen zu sein. Alle bisher getesteten Apps funktionieren aber einwandfrei.
    Komischerweise kommt er mir auch so vor, dass in vielen Apps auf einmal Werbung drin ist, die ich vorher nicht bemerkt habe.

    Gerade habe ich mal versucht über Titanium den Link zum Market wieder herzustellen (Market-Anbindung erzwungen). Die Ausführung wurde mir auch angezeigt – nur im Market sehe ich die App immer noch nicht.

    Nach einem Neubooten sind dann „komischerweise“ die Verlinkungen zum Market wieder weg :-(( Es steht wieder nur „GRATIS“. Ich krieg bald die Krise…

    Blöderweise funktioniert die Verlinkung bei einer Rückspielung auf 2.2f auch nicht (siehe weiter oben).

    Was tun????

Comments are closed.